Altera-opensource/linux-socfpga stuck at 4.13?


#1

Hello

Maybe I’m not asking at the right place, but I figured that somebody who know may be looking at the forum :slight_smile:

I was wondering why the altera-opensource/linux-socfpga github was still at latest tag being 4.13, while the mainline has past the 4.15 mark.

I can see continuous activity on kernel/git/arm/arm-soc.git, and even references to a ‘socfpga 4.16’ in the few ‘next’ branches. Also, up to 4.13, the socfpga branches seemed to pretty much follow the mainline dot releases.

Now, I know that a lot of the commits lately in the mainline have been for Spectre/Meltdown, but surely it’s not only because this… :slight_smile:

Also, mainline 4.15 seem to have catch-up with many of the socfpga 4.13 specific changes, so if I were to build a kernel, would it be fine to use the mainline 4.15 tag? Is there any major fixes past 4.15? I saw something about USB regression in some devices in 4.15, but mainly Arria10/Stratix10, but I’m targeting Cyclone-V (DE1-SoC).

Best regards,
Eric


#2

Hi Eric,
We have been using the 4.14 kernel for a Cyclone V SoC project lately and have not encountered any problems.
I have used the kernel.org git as a source to clone so I can get the minor updates that are pushed in the 4.14.x tags to stay up to date with the latest security patches.
I always used the github.com/torvalds or kernel.org git as the source and not the Altera git and has worked fine for me.
I don’t know about the 4.15 version because I haven’t tried it yet.

Regards,
Rienk


#3

Thanks, indeed, that was also my reasoning behind using an up to date kernel which is closer to master/HEAD than an older tag (like the ltsi for example).

However, after looking, there seem to be quite a few differences that followed the socfpga branches, which never made it to the mainline (the torvalds repe, i.e. from Linus himself). It’s easy to spot the differences by doing a compare between mainline 4.13 and socfpga-4.13.

Thanks for confirming that this work fine with the mainline kernel. I guess that at the beginning you had no choice to use the socfpga branch, but now many of the stuff has been merged to torvalds. I was wondering about those differences that are still remaining (some of them dating from many months). So I was wondering if I could get bit someday by not using the ‘official’ Altera(Intel) ‘approved’ branch.

For example, the socfpga branch arch/arm/mach-socfpga/Kconfig include the configs such as

  • select ARM_ERRATA_754322
  • select ARM_ERRATA_764369 if SMP
  • select ARM_ERRATA_775420
  • select PL310_ERRATA_588369
  • select PL310_ERRATA_727915
  • select PL310_ERRATA_753970 if PL310
  • select PL310_ERRATA_769419
    that is not in the mainline, and this is something that date back for a while.

I guess I could try to apply those diff to the latest kernel…

Regards,
Eric


#4

Me again!

Pretty good timing… socfpga-4.15 just came out this weekend :slight_smile:

Regards,
Eric