Arm DS w/ Stratix 10: Target Selection: "No platforms are available"

Hi RocketBoards,

I’m completely new to Arm DS & I’m trying to follow the Hello World example.

After associating a new “Model Connection” with my built project, I’m supposed to select my target platform in the “Target Selection” window.
The target selection is empty, and the window pops up with the following error:
“No platforms are available. Ensure that the correct configuration databases are selected in the Preferences / Arm DS / Configuration Database panel”

Trying to select “Add a New Model” comes up with the error “This feature is not enabled in this edition of the product”

Going to the “Window-tab / Preferences/ Arm DS-dropdown / Configuration Database-menu”, I verified that the database path points to “<my-path>/developmentstudio-2022.2/sw/debugger/configdb”, containing board-files as described in the documentation:

I’ve tried the “Rebuild database” & “Test platforms…” buttons, but I still don’t have any targets to select.

I tried searching this topic and found that this might be a licensing-issue. My FlexNet license file only contained “INCREMENT” lines for the compiler/debugger/profiler/suite originally. I manually added SERVER/VENDOR lines pointing to the host-pc ID & port, using the same <port>:<address> in the Arm DS Product Licenses window. Note that the “Activate Product” window has “Arm Development Studio Intel FPGA Edition” checked at the top, with a check by my <port>:<addr> license below.

Is there any way I can verify if Arm DS has applied my license successfully? After entering the license in Arm DS, the server logs alternate between:

“OUT: ds_suite_elm …”
“OUT: ds_compiler_elm …”
“IN: ds_suite_elm …”
“IN: ds_compiler_elm”

Any help would be appreciated,