Arria 10 SoC Dev Kit, Usb Uart - FPGA


#1

Hi, I need to use the usb-uart port of the development kit on the FPGA side of arria 10. When I traced the signals on schematic, I found that J18 and J19 pins are for tx and rx relatively. However, these pins are shared io pins (there is no HPS in my project) and when I tried to loopback from the fpga(I wrote a VHDL code that connects rx to tx directly and made necessary assignments on the pin planner.), I saw that rx pin picks up the coming signals ( I saw it on the signalTap) but there is no return(cant recive the data back ). I searched the user guide and the web and coulndt find anything usefull.

Please help

Related VHDL code is basically this:
uart_tx <= uart_rx;

uart_rx is assigned to PIN_J19
uart_tx is assigned to PIN_J18


#2

Hi ,
I’m working on Arria 10 SoC dev kit too, i’m sorry to ask you here but could please provide me with tutorial that help me manipulate the FPGA side of the board only (no HPS), i want to load a simple Quartus project into the FPGA.
Again i’m sorry for not providing any help for your problem.


#3

I only created a project and used quartus to compile and program the device . Are you new with FPGA’s ?


#4

yes i’m new , i learned how to run linux on the arm side of the board , and what i want to do is to configure (program) the FPGA side with a simple blinking LED project .
I’m not sure on how to do it when using SoCs , is there any initialization the HPS part before configuring the FPGA ?


#5

Hi,

I had same problem, too. Then ı realized that in the refence design they used K17 and M17 as usb uart pins. And used them instead. İt worked