Booting Zephyr on Agilex5: ATF BL2 not working

I am trying to boot Zephyr on an Intel Agilex5 SoC on a dev board but the BL2 preloader is not working.

As written on the Hard Processor System Booting User Guide for Agilex5 and on Zephyr website, the boot flow is ATF BL2 >> ATF BL31 >> Zephyr.

For the moment I am just focusing on loading the preloader BL2 on the QSPI flash. I expect BL2 to send some log over the serial terminal but nothing appears.

So these are the steps I do (tried both on WSL and on Ubuntu):

  1. Execute the instructions from the Building Arm Trusted Firmware section of the [RocketBoard tutorial] which give bl2.bin as output
  2. Transform the bl2.bin in bl2.hex (I tried also .ihex) using the following command:
    aarch64-none-linux-gnu-objcopy -v -I binary -O hex --change-addresses 0x00 bl2.bin bl2.hex
    The load address is set to 0x00 since the on-chip RAM is at address 0x00 in the Agilex5.
  3. Compile the Golden Hardware Reference Design on Quartus (and therefore generate the .sof). This design was taken from GitHub - ArrowElectronics/ghrd-socfpga
  4. Create the .jic file with the following command:
    quartus_pfg -c project.sof project.jic -o device=MT25QU01G -o flash_loader=A5ED065BB32AE4SR0 -o hps_path=/path/bl2.hex -o mode=ASX4
  5. Open a serial terminal
  6. Program the board from Quartus Programmer
  7. Push the NCONFIG button

Is there anyone who has already booted an OS using BL2 as preloader that can help me?

Thank you!