Can anyone help getting the SoCrates board to boot?

I have obtained an EBV SoCrates board and am trying to get it to do something, ideally boot into Linux. The serial port is detected on my win7 pc and I can connect to it via TeraTerm, however when I boot the board, nothing happens on the serial port. (I have tried at various baud rates ex: 57600 & 115200). I have also obtained the sd card image for this board and copied it to the sd card (which I think is formatted ok). Again when I boot the board with the sd card in, nothing is outputted to the serial port. Any ideas would be greatly welcomed.

I’m assuming by detecting it and connecting to TeraTerm you’ve installed the drivers for the UART, so that shouldn’t be the problem. What do you mean by “copied” to the sd card? You shouldn’t have to format it since when you write the entire image it writes over the entire card itself. What program are you using to write the card? Is it the windows imager tool or are you using a Linux host as well?

yes the drivers for both the usb blaster and serial port have been installed.I am using a Windows 7 pc and tried to use Win32DiskImager to write to the sd card, however this looks for a .img and the supplied files are not in this format. I have tried copying the supplied files to the sd card, but this doesn’t seem to work either. I think the baud rate for the serial port is 57600, but have tried numerous other baud rates with no success.I appreciate any help you can give me.

Try following this project here:

At the very bottom there’s a link to a training with the socrates board that should get you a working Linux prompt. I checked out the SD card files you’re talking about, and you’re right it’s not an image. The files provided are only part of what you need for a Linux install.

@triffel: Yes indeed - we provide a tarball with all individual components and a short script that is used to assemble them into an attached sd card. This has the advantage to make swapping individual items very easy and it also uses the full card capacity for the Linux filesystem as all available space is used. Also the script is very short (128 lines currently) so it can be used as a reference on what is needed to assemble a fully working SD card.

As the required tools are all available under GNU/Linux and doing embedded Linux development sooner or later needs a real GNU/Linux system on the host anyway, we feel that this is a good way of doing things.

@ldra_mwr: The SoCrates boards are delivered with a working SD card. You should really try to get the setup correct until you see an output on the console at 115000 baud. As the jumpers are setup for boot form MMC you will only see something with an inserted SD card. Otherwise the CPU cannot even find a preloader and nothing is output.

This is now working for me. A colleague of mine who is much more familiar with Linux has run the script and the sd card is now correctly programmed and the board boots into Linux. Many thanks for your help.

Thanks for the confirmation. It’s good to know that it now works for you.