Can't SSH into new Sockit board... how to install openssh-server

I have a new Cyclone V Sockit board rev D.
I was able to get the linux image SoCKit_RevD_LXDE.img written to an SD card and booted into Linux.
After getting networking working, I tried to ssh into the new board. No luck. Apparently the ssh client is there, but no server, so it appears I need to install openssh-server.

After changing /etc/apt/sources.list to use http://old-releases/ quantal main universe, my apt-get update seems to work fine, as follows:

root@localhost:/etc/apt# less sources.list
deb quantal main universe
deb-src quantal main universe
root@localhost:/etc/apt# sudo apt-get update
Ign quantal InRelease
Ign quantal InRelease
Hit quantal Release.gpg
Hit quantal Release.gpg
Hit quantal Release
Hit quantal Release
Hit quantal/main Sources
Hit quantal/main Sources
Hit quantal/main armhf Packages
Hit quantal/universe Sources
Hit quantal/main armhf Packages
Hit quantal/universe armhf Packages
Hit quantal/main Translation-en
Hit quantal/universe Translation-en
Ign quantal/main Translation-en
Reading package lists... Done

However when trying to do apt-get install openssh-server, I get the following errors:

root@localhost:~# apt-get install openssh-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  ca-certificates openssl ssh-import-id
Suggested packages:
  ssh-askpass rssh molly-guard openssh-blacklist openssh-blacklist-extra ufw
The following NEW packages will be installed:
  ca-certificates openssh-server openssl ssh-import-id
0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 521 kB/1001 kB of archives.
After this operation, 1872 kB of additional disk space will be used.
Do you want to continue [Y/n]?
WARNING: The following packages cannot be authenticated!
  openssl ca-certificates openssh-server ssh-import-id
Authentication warning overridden.
Err quantal/main openssl armhf 1.0.1c-3ubuntu2.5~linaro1
  404  Not Found
Failed to fetch  404  Not Found
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

So how do I get this working so I can ssh into the board?


Was able to get it working by adding --fix-missing option.
I had tried that option before I had changed the repository to old-releases, so when it didn’t work I figured the option was probably not doing much.