Connecting camera to DE0-NANO-SOC

Hi,

I am trying to connect Logitech c170 to DE0-NANO-SOC that is attached to the Terasic spider robot through USB. The problem is that it looks like the board has a minimal Linux distribution. there is not package managers (e.g. apt-get) and when I try to connect the camera there is no video folder in /dev.
I researched online and I found that I need to recompile the kernel to enable uvc and copy the new kernel to sd card. I tried to compile with the altera-socfpga original kernel using toolchain i think and i tried angstrom using yocto. Both of them when i open menuconfig menu multimedia support is empty and there is uvc enable option.

i have the d5m but there are no drivers available for de0-nano-soc.

please help me, i have to finish my senior project using this board.

Thanks.

I saw someone use D5M on this board. Maybe there is a solution´╝č

Hi!
We have now the D5M camera working on DE1-SoC at 47fps 640x480 with decent colors in https://github.com/jlrandulfe/UviSpace.

In the FPGA there is a camera config component for camera configuration. There is a camera_capture that takes images from camera. Then pixels are converted to RGB and send to VGA passing through a SDRAM fifo.

When you load the FPGA project and run the https://github.com/jlrandulfe/UviSpace/tree/DE1-SoC/DE1-SoC/HPS/test_programs/camera_vga_test you can see the result in the VGA. The problem is that your board has nor VGA and the image needs to be acquired by processor and sent via ethernet. We are working on that now. We did a image_capture image that saves image lines in HPS OnChip RAM. When a line finishes the processor copies it to its RAM to leave space for the next lines in the HPS OCR. It is still in debugging. We have the problem that sometimes the OS takes the processor and lines are not moved in time and data is lost. We will have it soon.

Maybe you can use the streaming and try to do your own peripheral to copy images into the processor. You can remove the VGA part and change the pin assignments to port to your board. But at least tyou have the camera configuration already done.

Hope it helps. Cheers!

Thank you for your response,I wish you posted this earlier, i could have used it in my design.
I was working on it like you and i was able to reach up to clocked video input on the FPGA but I did not bridge it to the HPS because i had to finish my senior project and i had no time to work on it. Therefore, i moved to the usb camera. i was able to recompile the kernel with USB video support (UVC) using the following tutorial:
https://eewiki.net/display/linuxonarm/DE0-Nano-SoC+Kit
I also installed Ubuntu filesystem and OpenCV library.