DNS and /etc/resolv.conf


#1

Perhaps just a misunderstanding on my part, but when I boot my board (Arria 10 SoC dev board) into Linux (prebuilt Angstrom v2015.12 from rocketboards), the file /etc/resolv.conf still has just default values in it. I think they are pointing to Google DNS servers:

root@arria10:~# cat /etc/resolv.conf 
# This file is managed by systemd-resolved(8). Do not edit.
#
# Third party programs must not access this file directly, but
# only through the symlink at /etc/resolv.conf. To manage
# resolv.conf(5) in a different way, replace the symlink by a
# static file or a different symlink.

nameserver 8.8.8.8
nameserver 8.8.4.4
nameserver 2001:4860:4860::8888
# Too many DNS servers configured, the following entries may be ignored.
nameserver 2001:4860:4860::8844

The board gets an IP address with no problem, though.

It’s only after I run udhcpc that the file gets updated with the correct, local DNS servers on my network:

root@arria10:~# udhcpc
udhcpc (v1.23.2) started
run-parts: /etc/udhcpc.d/00avahi-autoipd exited with code 1
Sending discover…
Sending select for x.x.69.176…
Lease of x.x.69.176 obtained, lease time 43200
run-parts: /etc/udhcpc.d/00avahi-autoipd exited with code 1
/etc/udhcpc.d/50default: Adding DNS x.x.2.1
/etc/udhcpc.d/50default: Adding DNS x.x.224.196
/etc/udhcpc.d/50default: Adding DNS x.x.86.116

root@arria10:~# cat /etc/resolv.conf
domain xx.xx.com
nameserver x.x.2.1
nameserver x.x.224.196
nameserver x.x.86.116
root@arria10:~#

(I’ve obfuscated the IPs just in case)

Shouldn’t systemd/networkd update the DNS stuff in /etc/resolv.conf at the same time it’s getting an IP address through DHCP?? I tried searching numerous forums but couldn’t find anything useful.

Thanks!