DS-5 debugging problem ARRIA V SoC with Angström


#1

Hi,

(Win7, altera ARRIA-V Dev board, DS-5 v5.22.0)

I’m trying to debug the simple Hello Word example with the SoC, I get the following error when I launch the debugger:

  Remote shell is not responding : Timed out executing command on target: PS1=#''@#DS5#@@eiKanIn3#

Shell console, ssh, sftp, … works correctly. Debug configuration is as the one in the user guide "ug_soc_eds_.pdf"
Debugging was successful one time only.

Any advice ?
Thanks,
Olivier


#2

I am using Angstrong in Terasic DE1-SoC with CycloneV SoC. In my case gdb server is not installed in Angstrong so when clicking on debug the file is copied into the filesystem on the SD card connected to the board but debug fails. You can navigate to your home folder using the serial console and execute from there the file using ./filename. If you want to debug I supose you have to install gdb server on Angstrong.
However the Poky OS (called DE1-SoC_Console.img in the case of Terasic) has gdb server installed and I could debug following the steps in the tutorial.

Hope it helps
Bye!


#3

Hi roberbot,

In my case, gdbserver is installed on the target (it was not the case with the SD Card supplied with the kit, then I downloaded and write a good angtrom distro in the SD card), I can run it manually and do all the debugging manually with connexion to the host. The problem is that if I want to do this automatically (option in the debug configuration to upload file to target, start gdbserver and start debugging) DS-5 fails with the message above. I think it fails just a the beginning of the script (upload the file to the target) but I don’t know why. I tried with Win7 and with Ubuntu 14.04 -> Same error.

Anyway, thank for your message,

Olivier


#4

Hi Olivier, did you ever resolve this?

I’m currently having the same problem debugging with my SoCKit Cyclone V Board.

I’ve tried DS-5 5.22.0 and 5.20.2 on Ubuntu 12.04. I’ve added gdbserver to Angstrom. Everything else works fine, including manually starting the application and gdbserver on the target, and then connecting to the running gdbserver with DS-5.

Has anyone else run into this?

Thanks.


#5

Hi Huntero,

No, then I do this workaround: Start gdbserver on the target, then do a direct debugging session with the “Connect to already running gdbserver”. This method works fine.
I think that there is a problem with the script in the “Download and debug application”.

Regards,

Olivier


#6

Hi,

Did someone find how to use the “Download and debug application” feature ?

Regards,
Mehdi


#7

I’m using the Arria 10 and running into the same issue. I’m following the steps from the SoC EDS Getting Started guide in the altera wiki (http://www.alterawiki.com/wiki/SoCEDSGettingStarted#Getting_Started_with_Baremetal_Project_Management) verbatim, substituting “Arria 10” for “Cyclone V”, but no luck.

Like monnoliv said, starting the gdbserver manually on the target and choosing “Connect to already running gdbserver” worked for me as well.


#8

it seems that DS debugger waits for a specific magic prompt string to issue commands, but for some strange reason for some unlucky guys, including me, it fails to setup this prompt on the target board.

The solution, that helped me, is to setup the required shell prompt string in the Linux on-board. Just open there /etc/profile and edit the PS1 setup string to be

PS1=’#@#DS5#@@eiKanIn3#’

(then check at the next login that the prompt is actually looks like this dummy string)

Good luck in debugging!


#9

I have an idea for you.
1/ If you are using Angstrong OS. You should check your OS have be installed gdbserver via this command:
$ gdbserver --version
If it’s not installed, I advise you should change another OS. Go to terasic.com and download Ubuntu OS for you board. Because you can download gdbserver package from Debian’s server.
$ sudo apt-get install gdbserver
2/ After you have gdbserver you will set up gdbserver for your board via this command
$ gdbserver root@‘your id eth0’:2000 <your program you want to debug ‘binary file’>
2000 is a TCP port, you can change to 5000 or any number
After that your board are listening your host machine.
Ok -> Go Eclipse -> Debug Configuaration -> Linux Application -> Connect to already running gdbserver
Adress: 'your eth0 ID’
Port: 'That port you set before’
File: ‘Choose your binary file’
-> Debug
Done. Good Luck
Dang Ho


#10

[Deleting previous post how cleaning up DS-5 Eclipse seemed to help, which turned out to actually be a fluke.]

My true success story is to create another user other than “root” to connect with when using the debugger. Seems if the RSE SSH connection is logged in as root, specifically user and group ID’s = 0, then the error occurs:

Remote shell is not responding : Timed out executing command on target: PS1=#’’@#DS5#@@eiKanIn3#

Hopefully may be a clue to someone as to what is really going wrong along with that using root still works when debugging from DS-5 on targets running the previous Yocto distributions and not on the newer Angstrom.