Error Building Rootfs and Kernel Image Using Angstrom 2018.06 distribution


#1

Note: butchering all links with dot because I am a new user and I can’t post more than two links…kind of makes this hard…hint…hint…

Followed instructions (https://rocketboards_dot_org/foswiki/Documentation/GSRDCompilingLinux_S10) through bitbake step, when I got the following error:

ERROR: ExpansionError during parsing /home/user/angstrom-build/layers/meta-altera-refdes/recipes-devtools/socfpga-test/socfpga-test_1.0.bb
Traceback (most recent call last):
bb.data_smart.ExpansionError: Failure expanding variable SRCPV, expression was ${@bb.fetch2.get_srcrev(d)} which triggered exception FetchError: Fetcher failure: Fetch command export PSEUDO_DISABLED=1; export DBUS_SESSION_BUS_ADDRESS=“unix:abstract=/tmp/dbus-O6zcEphkec”; export SSH_AUTH_SOCK="/run/user/1000/keyring-rcMNNC/ssh"; export GIT_PROXY_COMMAND=“oe-git-proxy”; export all_proxy=“socks.ext.replaced_dot_com:1080/”; export ALL_PROXY=“socks.ext.replaced_dot_com:1080/”; export no_proxy=“http://replaced_dot_com:80/”; export NO_PROXY=“http://replaced_dot_com:80/”; export ftp_proxy=“ftp://proxy.ext.replaced_dot_com:80/”; export https_proxy=“https://proxy.ext.replaced_dot_com:80/”; export http_proxy=“http://proxy.ext.replaced_dot_com:80/”; export PATH="/home/user/angstrom-build/layers/openembedded-core/scripts:/home/user/angstrom-build/build/tmp-angstrom-glibc/work/aarch64-angstrom-linux/socfpga-test/1.0-r0/recipe-sysroot-native/usr/bin/aarch64-angstrom-linux:/home/user/angstrom-build/build/tmp-angstrom-glibc/work/aarch64-angstrom-linux/socfpga-test/1.0-r0/recipe-sysroot/usr/bin/crossscripts:/home/user/angstrom-build/build/tmp-angstrom-glibc/work/aarch64-angstrom-linux/socfpga-test/1.0-r0/recipe-sysroot-native/usr/sbin:/home/user/angstrom-build/build/tmp-angstrom-glibc/work/aarch64-angstrom-linux/socfpga-test/1.0-r0/recipe-sysroot-native/usr/bin:/home/user/angstrom-build/build/tmp-angstrom-glibc/work/aarch64-angstrom-linux/socfpga-test/1.0-r0/recipe-sysroot-native/sbin:/home/user/angstrom-build/build/tmp-angstrom-glibc/work/aarch64-angstrom-linux/socfpga-test/1.0-r0/recipe-sysroot-native/bin:/home/user/angstrom-build/bitbake/bin:/home/user/angstrom-build/build/tmp-angstrom-glibc/hosttools"; export HOME="/home/user"; git -c core.fsyncobjectfiles=0 ls-remote ssh://gitolite@at-git.intel.com/linux-test failed with exit code 128, output:
ssh: Could not resolve hostname at-git.intel_dot_com: Name or service not known
fatal: Could not read from remote repository.

I first thought this was related to our corporate firewall, but when I tried it at home, I got the same issue.


#2

Hi,
Same here; have you found a solution already?


#3

Not yet. I may try using this https://rocketboards.org/foswiki/Documentation/AngstromOnSoCFPGA_1 to build Angstrom.


#4

Thanks! I’ll try that too and send you a message when successful!
Cheers,
Richard


#5

Sorry, should have checked the link first…tried that one already and the download of the repo projects fails (feed link down or something like that);


#6

You are correct, sadly. It ( https://rocketboards.org/foswiki/Documentation/AngstromOnSoCFPGA_1) hangs trying to sync meta-gumstix-community. This happens whether or not you are behind a firewall. Both of these write-ups need to be updated so they will work as written.


#7

Any success with the GSRD? It looks like the page may have been tweaked, and mine is now failing in a different manner.


#8

I’m afraid not…I followed a how-to/tutorial some time ago (https://bitlog.it/hardware/building-embedded-linux-for-the-terasic-de10-nano-and-other-cyclone-v-soc-fpgas/) and this works OK except for the part where the linux kernel must be added to the sd card; is it an idea to contact the author of the work in the link together so he might check his own work and optionally send us an alternative solution?


#9

That is my frustration with having the wiki and the forums separated. It makes it extremely hard to get issues with wiki articles addressed.


#10

Yes, I agree. And, stupid enough, when I’ve been searching and struggling for weeks to get something going, I realise I have forgotten to write down how I got to the solution; so next time it’s the same struggle again…shall I see if I can contact the author (Oguz Meteer) of the how-to and let you know?


#11

That would be good. Thanks.


#12

I’ve sent him a mail; I’ll be in touch again when I’ve got a response!

Have a nice evening & cheers,
Richard


#13

With the revised instructions, I can now complete Step 3 (Rootfs and Kernel Image Using Angstrom 2018.06 distribution) outside of a firewall. Can’t get past all the hurdles within the firewall (will have to figure that out some time later). Still cannot do the 4th part (Building Kernel and U-Boot Separately From Git Trees).


#14

Hi Birk,
Ok, that’s one step further; I’ll try it too when I’ve time.
At the moment I am downloading the old altera linux kernel for the Cyclone V;
When I’ve got it, I’ll try to finish the steps from https://bitlog.it/hardware/building-embedded-linux-for-the-terasic-de10-nano-and-other-cyclone-v-soc-fpgas/; if everything works as I expect, I should be able to build the embedded linux as well.

Cheers,
Richard


#15

Hi Birk,
I got the FPGA programmed from the preloader and embedded linux booting afterwards; works just as described on the website I mentioned above. The communication with the FPGA works also just as described in the tutorial: from a C program as well as via a kernel driver. To me this means that I can now design a piece of hardware in Quartus, make it a component in QSys, build the device tree and recompile the embedded linux.
Any progress on your side?


#16

I was able to build the kernel, but when I went to part four of the instructions (u-boot), I found the instructions were lacking and there were broken links. It also appears something in the chain is out of date, so waiting for someone to fix the procedures. Glad you have been able to make progress. I was hoping they would keep refreshing their GSRD instructions to keep them working as open source inputs changed.


#17

Thanks Birk, hope you’ll be helped soon as well!