Ethernet not working after reboot

Hi all,

I have a problem where I flash an image on a custom board of mine, Ethernet link is up, an IP is assigned by udhcpc (version 1.29.3 from busybox) and a connection to the internet is established.

Then after a soft reboot, either (randomly) eth0 fails to be brought up or eth0 is detected but an IP cannot be given by the dhcp client no matter how many tries and setting a static IP doesn’t work either. If eth0 cannot be detected, a hard reboot will make it appear again but still no connection to the internet (dynamic or static).

I am using Buildroot-2019.02.04 to build my image, using kernel 4.14.73-ltsi and using a cyclone V socfpga.

Are there some registers that are not being completely cleared/reset and that’s why the reboot is causing issues? Or any other pointers would be highly appreciated. Please let me know also if I can share any useful logs or any other details.

Best Regards,

Hello @yoro,
well, comparation of booting messages of Linux kernel could be useful. Try to print here both cases. You can catch them with communicating with SoC via seriál link or with dmesg command.
Are there any information in the syslog (i.e. Linux system logging service)?
Do You have a driver for ethernet integrated into the kernel or do You use modular driver?
Yours Jan Konečný.

Hi Jan,

Thank you for your reply. Here are the logs. Bootup after flash and after a reboot, no IP assigned. Would not work no matter what.

https://zerobin.net/?61e2955cbfb0cb20#6uWlmYMPBdT5Sy7Wi95nacpH4jIhw/IdOcrBDdof+qM=

I haven’t seen any particular message in the syslog as well.
We are using the integrated driver from the kernel itself.

Note; Our system was running kernel 3.10 before and everything was working fine.

Thank you,

Hello @yoro,
well, messages of kernel (and driver of ethernet) seem me without problems according to my experience.
The only suspicious message I see is the following one (phase of shutting down during rebooting):

Stopping network: nohup: appending output to nohup.out

I have never mentioned similar messages, although I am using my own very light-weigthed distribution.
What is the content of the file ‘nohup.out’?

Hello @yoro,
could I ask if You has solved the problem?
Have a nice day…