FFT Workshop HPS - SoC Workshop not working with de1-soc 5CSEMA5F31C6

Hi everyone

Two colleagues of mine and I have invested a lot of time trying to reproduce the FFT workshop on the page https://rocketboards.org/foswiki/Documentation/SoCSWWS1IntroToAlteraSoCDevicesLab4LinuxFFTApplication but we just can’t get it running.

Some things we have tried, and problems we have had.

  • The SD Card image contains 3 partitions but when I insert it nothing boots, I don’t see anyhing on the serial output. I’ve sucessfully booted various images but the this one doesn’t boot out of the box

Device Boot Start End Sectors Size Id Type
/dev/sdb1 4096 528383 524288 256M b W95 FAT32
/dev/sdb2 528384 1048575 520192 254M 83 Linux
/dev/sdb3 2048 4095 2048 1M a2 unknown

  • My MSEL DIP Switch is off, on, off, on, off, off (from pin 0 to pin 5). My FPGA board is the Cyclone DE1-SoC Revision G 5CSEMA5F31C6.

  • So what we did next was build the preloader, bootloader and Linux rootfs by ourselves. This was successful and we booted. We then loaded the workshop provided fft.bin and *.rbf file to a FAT partition. We loaded the rbf file successfully to the FPGA. We then jump to the start address of the bin file inside the boodloader shell. We took the rbf that is on the SD Card inside the folder ALTERA_CV_SOC => nothing happend.

  • Next we didn’t do it bare metal we loaded the RBF pre-built binary and the booted to linux and ran the compiled fft_fpga program (binary compiled from the c-source). Here we had various attempts. At first we had a bus error, but it seem that was because the bridge had not been enabled. /dev/mem is visible in the device tree. Next we had some text output of just the prog-name and then nothing.

  • Next we used an example from the Live CD that does some light display HEX_LED its called. This worked. Here we were also able to rebuild the rbf and succesfully run it. We then edited this HEX_LED to incorporate all the elements of the the FFT found in the qsys project file. This built successfully and was loaded onto the fpga but we we got a segemntation error when running the fft_fpga program.

  • Other note: we had some difficulty building the preloader as the toolchain flow has changed, but we just downgraded to an older version of quartus and embedded toolchain and it worked.

Anyway, we would be very glad for any pointers / tipps how we can get the tutorial running. Perhaps someone knows how the sdcard can be booted, maybe the wrong MSEL? The wrong board?

Regards and thanks for reading! :grin: