Help with Soc Std 18.1 / DS-5 installation

Working on getting software installed while waiting for my dev board to arrive. Had a couple of issues while installing Soc Std which I resolved BUT the crappy installer is no help.

Installed on Linux Ubuntu 18.10, fixed two missing library issues and everything pretty much went through without hiccups but I didn’t run as sudo so I had to use option A to exit the DS-5 install and then…

I had to install the DS5 manually, and the pop up from the initial Soc installer said to run ds5_link from the embedded command shell after installing DS-5 to create the baremetal toolchain link.

I tried that but it says could not find the DS-5 installation directory. I used the default for installing DS-5 but that is different from the directory where Quartus Prime Lite is installed.

So do I need to delete the DS-5 installation from the default location /usr/local and reinstall it specifying ??? directory under where Quatus Prime Lite and SoC is installed? Or is there a way to tell the ds5_link executable where to look for the DS-5 installation?

I haven’t found any useful docs on this yet and a search here for installation problems didn’t yield anything.


I finally worked out how to specify the path for the ds5_link command, but the usage information from --help was incomplete so it took trial and error. Hopefully everything else will work correctly once I get my dev board.