Linux Console problem

I would like to ask if anybody has the same problem with serial link with Linux kernel versions 4.20 and higher?
I use to build my own Linux-based distribution with Buildroot. I am really not a begginer (customized U-Boot, light-weighted kernel, busybox, configuration, firewall, security programs, custom driver and daemons,…) but I could not find out any solution for this problem:
I have tried to upgrade to the latest versions two weeks ago. So I currently use Buildroot 2019.05.1 with Linux 5.1 (sourced from Compilation ends without any errors or warnings.
When I start my device (based on Cyclone V), kernel successfully boot and prints its messages to console (which is set to be default, ttyS0,115200). Kernel can print it’s messages to the console post booting but standard input and outputs seem to be redirected for all applications (getty as well as init and others). I am able to interact with the system via ethernet and SSH. Console (serial link) could not be used for any application any more. Only the first message (echo) of init is printed.
I tried to copy my version of Linux 4.9.78-ltsi which I used in the previous version of my system (I am able to swith kernels with U-Boot parameter). Everything (include Console) functions well with this old kernel, so I think the problem could be caused by new version of kernel.
I tried to configure and build many versions of kernel downto 4.20 and each of them has a described problem with console. I used to configure these testing kernels with default socfpga_defconfig to avoid any miss-configuration.
I would be grateful for any reaction. I am out of any idea past ten days of debugging.
Best regards and have a nice day wish
Jan Konečný.

1 Like