Linux not Booting on custom Intel Cyclone V board:

I was trying to build Linux file system from scratch for my Intel Cyclone V (5CSXFC6C6) board so I followed this (Embedded Linux Beginners Guide | Documentation | guide. But it did not work out due to “u-boot.scr” issues. I am using Ubuntu 18.04 and Quartus Prime Standard 18.1 edition.
Then, I tried the same procedure on Arrow SoCkit Evaluation Board 5CSXFC6D6F31C6N. The guide was accurate till step 8 (I wrote the preloader and u-boot.img on sd card and it gave the same output and errors of zImage as suggested in the guide) but since “rel_socfpga-4.1_15.09.01_pr” release is no more available for linux-socfpga from Altera, I had to opt for a newer version of linux-socfpga.
Now, newer versions of linux-socfpga do not support compilation using old “gcc-linaro-arm-linux-gnueabihf-4.9-2014.09_linux” as suggested in the guide, so I had to opt for a newer “gcc-linaro-6.5.0-2018.12-x86_64_arm-linux-gnueabihf”. I further used “socfpga-5.15.50-lts” as the new and stable version of linux-socfpga and buildroot to build the image but it also didn’t work out.

I tried another way (Building Bootloader for Cyclone V and Arria 10 | Documentation | with Quartus 19.1 but it failed at bitbake step. It gave 2 errors after downloading 5+ GBs of data.

I am stuck with this for more than 2 months. Can anyone suggest a better way?