Linux stuck at boot

#1

Hi, I am using cyclone V revision C. I successfully compiled my fpga design, made soc_system.rbf and copied it to fat partition of my sd card. I am using Linux sockit gsrd 13.1. I set up the SW6 settings as MSEL[0:4]= 010101 (FPP*32 compressed). Whenever I boot Linux, it is stuck at starting lighttpd webserver. can anyone suggest me what to do ? I tried changing the SW6 settings to 00000 but then FPGA is configured but LINUX booting is stuck. I again changed SW6 settings to 10000 and now Linux is booted successfully but my FPGA is not configured? Can anyone tell me isn’t there a way that FPGA is also configured together with my Linux successfully booted.

#2

Hi! MSEL [0: 4] = 10101 (FPP * 32 compressed) means that when converting RBF files from a sof file , you need to set the property “compressed”, then there shouldn’t be any problems

#3

Yea I know it and I already generated compressed RBF file but still it isn’t working. I am using quartus 13.0 service pack 1 edition.

#4

here … the fpga is configured correctly but Linux booting is stuck at this point. I generated compressed rbf file and set the board SW6 [4:0] to FPPx16:00110.

#5

Hi Muhammed,
Looking at your Linux boot-up, you are not getting an IP address. Your dhcp discovery is failing. Therefore, lighttpd probably will not startup correctly. Therefore, you will need to edit your startup script to turn off lighttpd from starting. You will need to take your rootfs.ext2 image and mount it on a Linux PC so that you can edit one of the startup scripts in /etc/init.d. Or you can just delete or rename the startup script that starts lighttpd. You can do this by using this linux command: sudo mount -oloop rootfs.ext2 /mnt/iso_1 which assumes you have a directory created in /mnt/ios_1 to mount your file system on.
Hope this helps.
pat

#6

Hey Pat,
thanks a lot for your reply. If I understood correct then I just plug in my microSD card into a Linux PC and then navigate to directory rootfs.ext2/mnt/ and then type the command sudo mount -oloop rootfs.ext2 /mnt/iso_1?
I shall be thankful to you if you can guide me a little bit on steps on how can I do it because I am really weak in Linux knowledge…

#7

Hi Muhammad,
Sorry for the delayed response.
Well, I would copy the rootfs.ext2 image that you created to a Linux PC.
Then you would create the directory /mnt/iso_1 on your Linux PC.
I’m not sure what your microSD card has on it.
For example, if you have a root file system in ext2 format then you can create a rootfs.ext2 image on your Linux PC. That is, when you plug in your microSD card into your Linux PC, the system will automount the directories. If using Ubuntu, they will be automounted in /media/‘username’ for example. Then you will have to create a rootfs.ext2 image from that file system. For example, using the command ‘sudo genext2fs -b 500000 -m 0 -d ROOTFS rootfs.ext2’ where ROOTFS is the name of the mounted file system. After creating the rootfs.ext2 file, you would have to copy it back to your microSD card using the ‘dd’ command, for example, ‘sudo dd if=./rootfs.ext2 of=/dev/mmcblk0p6’ where /dev/mmcblk0p6 is the partition/volume on the microSD card. You can find out which partition/volume is for the root file system on a microSd card by using the lsblk command on your Linux PC.
You can also just directly edit the mounted file system on your Linux PC in the /media/‘username’/ROOTFS directory if you do not want to create a new rootfs.ext2 image and copy it back.

Hope this helps.
pat

#8

You only have to use the command ‘sudo mount -oloop rootfs.ext2 /mnt/iso_1’ command if you already have a rootfs.ext2 image. If you just plug in your microSD card into your Linux PC, it will automount the root file system as describe in my last post. Then you can go to that directory and edit the init scripts directly.
pat

#9

Muhammad,
It will be difficult to guide you with steps unless I know the contents of your microSD card.
If you are able to take your microSD card and plug it into a Linux PC and then go to /media/‘username’ directory and take a screen shot after running the command ‘ls -la’ then I can help you from there.
Also, a screen shot of ‘lsblk’ would be helpful too.
pat

#10

Hi,
Sorry for late responce actually I got a bit ill so couldn’t follow up.
I figured out that the binary archieves that I downloaded say that I set up the FPGA configuration to FPP x32 mode while for Arrow sockit cyclone V boards this configuration is not supported because they support upto FPPx16 mode. I tried these binary archieves:
https://rocketboards.org/foswiki/Documentation/ArrowSoCKITEvaluationBoard151LinuxGettingStarted

So, now I need to figure out the way how can I get a binary archieve that supports FPPx16 mode. Can someone suggest me any solution on this ?