Make_sdimage.py - Error: Failed to copy [Solved]

Hi, for the past couple of weeks I’ve been trying to learn how Yocto, Intel SoCs and Embedded Linux works.

I have the Arrow SoCKit board (Cyclone V) and have been able to boot Linux using pre-combiled hardware and software files.

I feel like I’m starting to get the grasp of things and how they relate to each other, but I seem to have hit a wall.

I’m trying to create my own SD-card which boots Linux and the FPGA.
I have rebuilt all hardware and software files and gathered all the necessary files according to the GSRD into a folder along with the make_sdimage.py script.
But when I run the script I get “Error: Failed to copy zImage”.

I don’t understand why this doesn’t work.

Does anyone have any ideas?

EDIT: Picture

Thank you.
-aln

Solved.

I had copied link files instead of the real files.
I was also missing a step in the build prior to making the sdcard image.

Hello,

Could you please specify , which step you missed in build prior to making sd card image.
I am facing the same issue , but i havn’t used the linked file, I am using
zImage–4.14.73-ltsi+git0+57d7c2d96d-r0.2-arria10-20190802135756.bin to which zImage is linked.

Thanks in advance.