Problems setting up a baremetal environment for DE0-Nano-SoC (HWLibs)


My problem is as follow: setup a working host-environment to compile/program/run/debug a series of bare-metal examples on a DE0-Nano-SoC board.

Upon failing to follow user guide from the UG-1137, I identified the most probable solution for my problem would be a guide for the HWLib. However I run into problems.

As for the requirements, I have installed Quartus Prime Lite instead of Standard edition due to licensing. The rest is according to stated requirements.

The issue is that I can get past compiling examples (I follow the readme.txt from a relevant example’s subdirectory). When I activate I correct the $QUARTUS_ROOTDIR variable as it’s point to qprogrammer subdir (as stated in the readme). But I’m unable to lunch the Arm Development Studio IDE as the armds_ide is not a working scrpit/alias from within the Intel FPGA Embedded Command Shell.
I tried to import and build the examples directly into the ARM DS IDE, or compile them by hand using installed linaro’s installed compilers - with little luck.

I suspecting following issues:

  1. I’m having improperly set up environment on unsupported system (running Ubuntu 20.04),
  2. Parts of the toolchain were updated and are not expected to work with each other anymore,
  3. I’m following an incorrect/outdated guide.

My question is: is there a working example of a toolchain that would support working with bare-metal code on DE0-Nano-SoC?

I would be grateful for any suggestions!