SOCEDS and Nios2 EDS issue with Windows Defender

A recent Windows 10 update at our company set Windows Defender (WD) to actively protect our computers. As part of this WD is using ASLR (address space layout randomization) to change load addresses for executeable code and data. In order for the programs to be compatible with ASLR it needs to have been compiled with the /DYNAMICBASE switch. It appears that the cygwin1.dll and the .EXEs in intelFPGA_pro\17.0\embedded\host_tools\cygwin\bin and intelFPGA_pro\17.0\nios2eds\bin have not been compiled with that switch.
Googled advice from others who have dealt with this show setting the Windows Defender Exploit Settings for each executeable but Windows only allows settings for .EXEs. If anyone has seen this and has a solution that can be accomplished with the Windows Defender settings I would appreciate an update on it.
I am using Quartus v 17.0.2 but I have verified that the problem exists on versions up to 18.1 (and its quite possible that it goes farther up).


You could use 19.1, where it is required that you install Cygwin yourself to the proper directory:

That might have helped but I dread having to upgrade all my projects. I found the fix in using the Windows Defender dialog to reset the exploit settings for all the .EXE’s in the Cygwin directories. It was a bit time consuming but everything works the way it used to and will stay that way when new updates come out.

There are two directories that need this reset. The one in C:\intelFPGA_pro\17.0\embedded\host_tools\cygwin\bin (follow your similar install path) controls your interactive Cygwin command line window, and the directory in C:\intelFPGA_pro\17.0\quartus\bin64\cygwin\bin needs fixing to support your Nios2EDS development tools. Once the executeable programs have been reset to exclude ASLR checking all is ok again.