SSH Connection Problem


Hey guys,

I’ve been developing with the DE-0 Board (Atlas) and recently I’ve updated the build for the latest image provided (v1.1 - Angstrom).

The problem I’ve been facing is that I can’t ssh into the board now. When I do the ~ssh root@ I get ~Connection to closed by remote host.~ When I had the previous build (it was purely Yocto), I were able to ssh into it. Also, the network doesn’t work, even though I can ping the host ip through the board and the board IP through the host computer, thus I can’t use opkg. I’ve been looking around for some clue of what’s happening but none of the tutorials online could get it to work.

Oh, despite I’m not able to connect by the terminal, I can connect with Putty.

Someone has a clue of what may be happening? (I’m not very experienced with Linux).

Also, what is the main difference of compiling Angstrom and using that Image provided?


Hi guys,

I have the same problem that you but with the Arrow SoCKit Evaluation Board. I can ping both side but when I do the ssh root@ (this IP it’s just for my practical exercice), I get “closed by remote host” message. So, I tried to connect me on the board with putty in ssh but that doesn’t work. I don’t understand why? So if someone can help me that will be kind.




Are you using Angstrom or Yocto? Have you configured Putty as in the Start Guide tutorial? Haven’t had a putty problem yet, even though accessing the board from the terminal doesn’t work anymore.


I’m using Angstrom. Yes, I have well configured Putty but I got a message of error “Network error: Software caused connection abort” … Do you have an idea of ​​where the problem comes from?


Has anyone found any solution for this? I encountered a similar issue attempting to connect to an Arria10 SoC dev kit from Ubuntu 16.04.

Oddly enough, I am able to SSH to the dev kit from an Ubuntu 14.04 machine, or from a windows machine with Tera Term. Something appears to have changed in newer version of SSH, but I cannot figure out a way to get it to work on 16.04 (I also encounter the same issue trying to SSH to the dev kit from Mac OSX Sierra).


It seems Ubuntu 16.04 has some SSH problem. I read somewhere and someone said it might be a bug in this version, but I’m not sure.

I am able to use Putty or Minicom though cause it connects through SFTP…


I found a workaround today for Mac OSX Sierra as well as ubuntu 16.04. If you specify an AES cipher like the following:

ssh -oCiphers=aes256-ctr root@

It appears to connect correctly correctly, at least on my test setup. Likely other ciphers would work as well, but that (as well as aes128-ctr) worked for me.


I’ll take a look tomorrow once I get my hands on the board!


It worked! Thanks buddy =)


Actually I downgraded my Ubuntu from 16 to 14 and it works normally. It seems to be smthing with Ubuntu.


I have no idea of it.


WoW I was scratching my head for half a day…you are a life saver :smiley: (I am on 16.04 too)