Unable to boot updated SDcard (A10 SoC Devkit)


#21

Thanks, i would like to try it. I could learn some from it in any case though I would want to start by converting it to my Devkit. I am no longer sure where my problem lies so I am willing to try anything. I have a ticket open with Altera but so far no activity on it. I expect the project files will be too large to email. If so then do you have a Dropbox or some way to leave them somewhere and send me a link?.(If not I can give you my Dropbox password and you can leave it there.)

If I can get a flat HPD design to load I plan to post it for others. I can’t be the only person puzzling over this.

Thanks,
Jambie


#22

Let me know when you’ve downloaded it.
This dropbox link will only be good for today.
If you have more issue then I’ll see if I can quickly port it to the A10 dev kit.


#23

BTW - This project booted Linux on our hardware using an Arria 10 FPGA.


#24

I’ve downloaded it. I’m just now digging into it. I will keep you posted.

Mucho Gracias,
Jambie


#25

Converted the project to Quartus v17.0.2 and updated A10 type to 10as066n3f40e2sge2. Picking my way thru assigning pins locations and trimming as little as possible (but I will not have I2C devices that will make sense to your code so I’ll at least have to turn that off).


#26

I believe I have the problem solved. Thanks for the project help. I used the files and converted almost everything but got hung up an making new pin assignments for my devkit board (I may have had them right but I was being extra-cautious as I didn’t want to create conflicts that cause more problems). As I worked this I got a tip from a vendor to try a different version of GHRD to start since I would not have to modify (and insert new errors) and I would not be stuck because I don’t have the IP license to compile the GHRD. I am going to try to post my solution to a different thread since it really follows the ‘Flat Design’ issue more than the boot problem that the title of this thread is under. Thanks for your help.


#27

Great news and work!
Cheers!