Using Yocto to build for DE0-Nano-SoC

I have an Ubuntu 14.04 build machine (a virtual private server). I’ve cloned Yocto and was able to build their default Intel image to run on QEMU.

I then cloned meta-altera in to the poky directory and edited conf/local.conf to select the kernel (ltsi-rt 4.2) and tried to set MACHINE = "de0-nano-soc" but the build system didn’t recognize that machine. I changed it to cyclonev and tried to bitbake virtual/bootloader which largely behaved itself before failing.

Before I start digging in to errors I’d rather get myself building for my board.

Also I’m trying not to use the EDSSoc provided by Altera if possible. For one I could not install on my VPS because it needed XTERM and some other graphical dependency. I’m on the software side and don’t need the hardware tools nor will I use Eclipse. I had the impression I could build the kernel, bootloader, filesystem, and cross toolchain using Yocto.

PREFERRED_PROVIDER_virtual/kernel = "linux-altera-ltsi-rt"
PREFERRED_VERSION_linux-altera-ltsi-rt = "4.1%"
GCCVERSION = "linaro-5.2"
SDKGCCVERSION = "linaro-5.2"
DEFAULTTUNE = "cortexa9hf-neon"
#MACHINE = "de0-nano-soc"
MACHINE = "cyclone5"

you can perfectly do this without Altera’s SoCEDS.
Your configuration looks good, for the bootloader I also added
UBOOT_CONFIG = "de0-nano-soc"
for this specific board. The default board would be cyclone5-socdk otherwise.
See meta-altera/conf/machine/cyclone5.conf.

Best Regards,