Why I can't control the LED? "Failed opening fifo frequency_fifo_scroll"

I am using MACNICA_HELIO v1.3 to do some work。
I have build a kernel and rootfs with Anstrom, the version is:

The Angstrom Distribution cyclone5 ttyS0

Angstrom v2014.12 - Kernel 3.10.31-ltsi+
but I can’t run the sample in folder /home/root/altera, when I run the command ./scroll_client, the result is:
root@cyclone5:~/altera# ls
blink hello scroll_client syschk toggle
root@cyclone5:~/altera# ./scroll_client -1
Failed opening fifo frequency_fifo_scroll
who can tell me the reason. thanks.
Some informaion:
there is no file in /sys/class/leds, and there is no folder /sys/bus/platform/drivers/leds-gpio.

  1. You need to check the FPGA functionality.

  2. You may need to update EPCQ on the board.

Thank you. I have not understand the reason and your explantion now.
I have tried other prebuild image and I found GSRD13.1 works well, and some other images have
not the altera example.
But, I have used the follow code implement the function for controling Leds:

    custom_led_map = (uint32_t*)(lw_bridge_map + CUSTOM_LEDS_0_BASE);

    // Blink the LED ten times
    printf("开始%s LED %d...\n", light_status? "打开":"关闭", light_number);
    orignal_status = *custom_led_map;
        // Turn all LEDs on
        orignal_status |= (0x1<<light_number);
        orignal_status &= ~(0x1<<light_number);
    *custom_led_map = orignal_status;

Just experienced the same problem with Stratix 10 SX Dev Kit, “out of the box”.

The work around is to manually create a directory and a couple files.
$ mkdir /home/root/.altera
$ touch frequency_fifo_scroll
$ touch get_scroll_fifo

I can’t figure out who to info of this problem. Maybe this post will be seen by the right person to make a fix.