Building uboot using yocto

i am trying to build uboot using yocto and i do not see the folder that the link shows. i do not see the ~/build/tmp/work/armv7ahf-vfp-neon-poky-linux-gnueabi/u-boot-altera-dist-1.0-r0/uboot-socfpga/board/altera/socfpga/build.h file. instead below is what i see.

can you please help in this regard? I am not sure what wrong i am doing here. i have yocto installed properly. As you can see the folder u-boot-altera-dis-1.0-r0 does not exist for me when i run bitbake u-boot

What recipe-image are you trying to bake? can you put the bitbake argument that you used?
You have another issue regarding sysroot_populate task it looks like a tar miss behavior/configuration if you don’t solve this issue before you will not be able to create a sysroot at all so you will need to focus on this issue if you want to create a loadable image, if you don’t mind and you just want to create u-boot image you could try

$bitbake -f virtual/bootloader

If you want to see the u-boot code within your tmp/work try

$bitbake -f -c configure virtual/bootloader

thanks for getting back, the argument that i used was bitbake virtual/bootloader . i followed the procedure on the link

pardon my ignorance but i am very new to this. how do i fix the sysroot issue? i have installed all the necessary packages except for the ia32-libs . i run into issue when i try to install this. i looked all over and couldnt find a way to install that package.

just came across this below link that says i need to downgrade to ubuntu 12.04. i am currently running 16.04. i wonder if its still the case.

and something similar here…

based on the comments it looks like there is an issue with tar version… do you already tried to downgrade tar?

i havent yet. i am in the process of doing that .